Руководство пользователя

 Top Next

Программа CreateModifyTestsV4Lite предназначена для создания и редактирования учебных тестов.

Программа позволяет создавать форматированные вопросы теста и их варианты ответов, задать параметры отображения теста, который будет далее воспроизведен программой TestingV4Lite.

С помощью программы можно открыть или добавить тесты предыдущих версий 3,4.

Созданные тесты сохраняются в собственном(зашифрованном) формате в файлах с расширением *.tbaa.

Если у Вас возникали проблемы с тестами более ранних версий, то необходимо сделать следующее:

1. Открыть тест программой CreateModifyTestsV4Lite.exe.

2. Выполнить автоматическую проверку теста путем нажатия на кнопку "Проверка".

3. Исправить ошибки, которые нашел модуль проверки.

4. Сохранить тест (он уже будет сохранен в формате версии 4 Lite).

5. Если после этой последовательности у Вас все еще возникают проблемы- следует использовать Авторы. Обратная связь.


Характеристика версии 3

 Top Previous Next

1. Появилась кнопка сброса критериев оценок. Ей необходимо воспользоваться если при проверке теста - выдается ошибка о некорректных критериях.

2. Поля редактирования критериев оценок защищены от изменения методом ввода числа с клавиатуры. В более ранних версиях эта возможность, при неправильном использовании, могла привести к некорректному их отображению.

3. Появился параметр - "Полноэкранный режим при воспроизведении". Это дает возможность вне зависимости от разрешения экрана и размерах, заданных при создании теста, проигрывать его в полноэкранном режиме.

4. Появилась возможность обьединения тестов. Она осуществляется по нажатию на кнопку "Добавить".

5. В разделе группы - для изменения группы - достаточно 2 раза щелкнуть на ней мышью.

6. Перед удалением вопроса теперь появляется диалог об уверенности, что защищает от ошибочного нажатия на кнопку удаления вопроса.

7. В разделе группы появилась колонка "Реальное кол-во вопросов", что дает более наглядное представление при проектировании теста.

Версия 3 читает и воспроизводит тесты версий 1,2,3. В тоже время программы, более ранней версии, не смогут прочитать или воспроизвести тесты, записанные версией программы 3 (совместимость сверху вниз).


Системные требования

1. Операционная система Microsoft Windows 2000 или выше.

2. Рекомендуется - Microsoft Office 2000 или выше.


Установка

Программа представляет собой исполняемый CreateModifyTestsV4Lite.exe файл и для установки необходимо переписать ее в рабочую директорию совместно с этим файлом справки CreateModifyTestsV4Lite.chm. После этого необходимо проверить, что пользователю от имени которого запускается программа, дан полный доступ на рабочую директорию(иначе программа при запуске будет выдавать соответствующее сообщение).


Данные теста

На вкладке Данные теста определяются следующие характеристики теста:

Дисциплина - название дисциплины по которой проводится тестирование

Тема - тема теста

Автор теста - проектировщик теста

Порядок воспроизведения вопросов - имеется возможность задания одного из 3 вариантов:

a) от первого к последнему - строго заданный порядок; будет проводится воспроизведение в прямой последовательности заполнения вопросов проектировщиком теста.

б) от последнего к первому- строго заданный порядок; будет проводится воспроизведение в обратной последовательности заполнения вопросов проектировщиком теста.

в) случайный - означает, что вопросы будут перемешиваться в случайном порядке.

Описание теста - данное необязательное memo поле будет появляться в качестве комментария при выборе теста в программе Testing.

Группы - имеется возможность разбиения вопросов по группам (например легкая,средняя и сложная) для управления количеством вопросов из каждой группы, которые войдут в тест. Например если определено 100 вопросов и заданы группы и кол-во вопросов:

легкая-30

средняя-20

сложная-10

то в тест войдут 60 вопросов. Если для некоторой группы задано количество вопросов превышающее реально существующее, то в тест войдет реально существующее количество вопросов. Если группы не определены, то в тест войдут все вопросы.


Параметры

На вкладке Параметры имеется возможность определить следующие параметры отображения теста:

Показывать бал сложности - при тестировании будет показан бал сложности вопроса

Показывать время затраченное на ответы.

Показывать комментарий - при тестировании для каждого вопроса будет показано уведомление о том сколько правильных ответов имеется на вопрос.

Показывать результат тестирования - по окончании тестирования будет выведено сообщение о количестве правильных ответов и оценка за пройденный тест.

Показывать сколько времени осталось - если включен режим ограничения времени тестирования, то будет отображаться оставшееся время.

Показывать результат ответа на вопрос - после ответа на вопрос будет выдаваться сообщение о правильности ответа.

Показывать сумму набранных балов.

Критерии оценок - имеется возможность установить зависимость результирующей оценки(по 10-бальной шкале) от количества набранных балов.

Пароль доступа - если задан непустой пароль, то после сохранения данный тест можно будет снова просмотреть или изменить только предварительно введя пароль доступа.

При тестировании перемешивать варианты ответов - если этот CheckBox включен, то варианты ответов будут отображаться в случайном порядке.

Возможность при тестировании пропустить вопросы - можно установить количество пропускаемых вопросов.

Ограничение времени тестирования - при включении данного режима, тест будет прерван по истечении заданного времени тестирования.

Возможность ответить позже на x вопросов - после пропуска вопросов они добавляются в конец списка отображаемых вопросов и далее имеется возможность ответить на x из них.

Полноэкранный режим при воспроизведении - дает возможность независимо от размеров, заданных при созданнии теста и от разрешения экрана(при воспроизведении), при воспроизведении использовать весь экран.

Критерии оценки - если опция включена, то критерии оценки увидит тестируемый.

Записывать подробный протокол тестирования - если опция включена, то по окончании тестирования программа TestingV4.exe создаст подробный файл протокола в виде файла *.xls. Подробности.


Вопросы и ответы

Последнее определение шрифта вопроса переносится на следующий вопрос. Аналогичная ситуация происходит и с ответами.

Существует возможность вставки изображений из файлов следующих форматов *.jpeg, *.gif, *.bmp, *.ico, *.emf, *.wmf.

Возможна вставка любого содержимого из документов Microsoft Office стандартными средствами.

Высота полей вопросов и ответов задается сплитерами с помощью мыши.


Кнопки

Кнопка Новый - позволяет в любой момент начать новый тест.

Кнопка Открыть - позволяет в любой момент открыть существующий тест.

Кнопка Добавить - позволяет добавить тест к уже сформированному- осуществляет слияние. При слиянии тестов параметры и данные теста наследуются от первого, за исключением групп. Группы обьединяются.

Кнопка Сохранить - позволяет в любой момент сохранить результаты проектирования теста в файл с расширением *.tbaa.

Кнопка Проверка - осуществляет проверку спроектированного теста на корректность. Настоятельно рекомендуется использовать эту кнопку после любых изменениях в тесте.

Кнопка Помощь - вызывает этот файл справки. Файл справки должен находится в одной директории с программой.


Авторы. Обратная связь.

 Top Previous

Разработчик программы:

Разуванов Александр Леонидович

Обратная связь:

admin@baa.by