Руководство пользователя

 Top Next

Программа TestingV3 предназаначена для проведения тестирования учащихся с помощью тестов, созданных программой CreateModifyTestsV3 (или более ранних версий).

Программа исполняет заданный тест и записывает результат тестирования в файл результатов (при необходимости результат показывается по окончании тестирования в виде сообщения).

Все необходимые параметры теста задаются при проектировании теста с помомощью программы CreateModifyTestsV3.


Что нового

 Top Previous Next

1. Данная версия характеризуется прежде всего корректной работой в сети. В более ранних версиях существовали 4 основные сетевые проблемы, 3 из которых(а,б,в) разрешены в данной версии:

а) невозможность одновременной записи результата c нескольких машин в файл результатов.

б) невозможность изоляции файла результатов от тестируемых.

в) невозможность изоляции, по записи, файлов тестов от тестирумых.

г) невозможность записи результатов более чем с 9 машин в один файл при условии использования не серверных платформ Windows.

Более подробно о корректной работе в сети см. Порядок работы в сети .

2. Решена проблема независимого безопасного просмотра файла результатов(во время тестирования) преподавателем.

3. Решена проблема совместимости. Для записи результатов используется клиент Microsoft Excel. В более ранних версиях запись производилась в формате того клиента, который был установлен по умолчанию на локальной машине, что приводило к проблеме совместимости Excel. В данной версии используется формат совместимости c Excel 95, что приводит к корректной записи результатов с любых клиентов.

4. Усилена устойчивость программы к обману путем модификации результирующих данных. Более подробно см. Параметры

5. Появилась возможность при тестировании вводить "курс" и "группа" тестируемого, что позволяет, в дальнейшем, пользоваться встроенной сортировкой Excel.

6. Программа данной версии позволяет использовать полноэкранный режим воспроизведения тестов, который задается, при необходимости, в программе CreateModifyTestV3.

7. В разделе выбора тестов теперь 2 колонки - Дисциплина и Тема.

8. Исправлены ошибки и неточности предыдущих версий.

Версия программы 3 читает и воспроизводит тесты версий 1,2,3. В тоже время программы, более ранних версий, не смогут прочитать или воспроизвести тесты версии 3 (совместимость сверху вниз).


Системные требования

1. Операционная система Microsoft Windows 2000 или выше.

2. Microsoft Office 95 или выше.


Установка

Программа представляет собой исполняемый Testing.exe файл и для установки необходимо ее переписать в рабочую директорию совместно с этим файлом справки Testing.chm. Необходимо проверить, что пользователю Windows, от имени которого будет запускаться программа, дан полный доступ на рабочую директорию.

После первого запуска в рабочей директории программы должны появиться 2 дополнительные служебные программы: SaveResult.exe и ViewResultTesting.exe, которые в дальнейшем будут вызываться из основной.


Порядок работы

Порядок работы студента:

1. Ввести фамилию, имя, отчество, курс и группу для идентификации пользователя.

2. Выбрать нужный тест из списка. Если в списке нет тестов, то необходимо с помощью кнопки Параметры определить правильный путь к файлам тестов.

3. Начать тестирование с помощью одноименной кнопки

Результаты тестирования записываются в файл Microsoft Excel, путь к которому задается в разделе Параметры. Начальный пароль для просмотра пути файла результатов и защиты листа результатов сообщается преподавателю разработчиком программы.

Если вы используете программу в сети, то необходимо прочитать пункт Порядок работы в сети .

Порядок настройки программы на безопасную работу:

Далее предполагается, что есть 2 пользователя Windows "Преподаватель" и "Студент" и программа будет запускаться в сеансе пользователя Студент.

1. Зайти в сеанс Windows как Преподаватель.

2. Настроить Безопасность папки с тестами следующим образом: пользователю Студент разрешить доступ только на чтение.

3.Настроить Безопасность папки с файлом результата следующим образом: пользователя Студент удалить из списка участников безопасности.

4. Настроить безопасность рабочей папки программы следующим образом: пользователю Студент дать полный доступ.

5. Войти в сеанс Windows как Студент.

6.Запустить программу TestingV3 и настроить параметры следующим образом:

a) Указать путь расположения файлов тестов.

б) Указать путь к файлу результатов.

в) Отметить "галочки" Блокировать попытки обмана программы и Помечать попытки обмана словом ...(ввести удобное... слово).

г) Отметить "галочку" запись/чтение результата от имени.

д) В полях Пользователь,Пароль,Домен ввести данные учетной записи Windows Преподавателя.

7. Нажать кнопку "Проверить" - если проверка прошла успешно(сообщение об успешной записи) см. следующий пункт, если было выдано сообщение об ошибке, то необходимо еще раз пройтись по пунктам, начиная с 1 и корректно выставить параметры.

8. Нажать кнопку "Безопасный просмотр результатов" - при корректных настройках Вы увидите файл результатов с "Тестовой записью".

9. Сменить пароль используемый по умолчанию.


Порядок работы в сети

Порядок настройки программы на безопасную работу в сети:

Далее предполагается, что есть 2 пользователя сети Windows "Преподаватель" и "Студент" и программа будет запускаться в сеансе пользователя Студент.

1. Создать на сервере 2 папки: первая(например ResultTesting)-для хранения файла результатов, вторая(например Tests) для хранения файлов тестов.

2. Настроить общий доступ и безопасность папки ResultTesting следующим образом:

пользователю "Преподаватель" дать полный доступ, а все остальные записи удалить.

3 .Настроить общий доступ и безопасность папки Tests следующим образом:

пользователю "Преподаватель" дать полный доступ, пользователю "Студент" дать доступ только на чтение, а все остальные записи удалить.

4. Заполнить папку Tests требуемыми тестами.

Далее будет описана настройка клиента, которую необходимо выполнить на всех машинах.

5. Зайти в сеанс Windows как "Преподаватель" на клиентской машине и переписать программу в какую-нибудь рабочую директорию(не следует размещать физически программу на рабочем столе по соображениям безопасности).

6. Настроить безопасность рабочей папки программы следующим образом: пользователю Студент дать полный доступ.

7. Запустить программу, войти в раздел "Параметры" и настроить их следующим образом:

a) Указать сетевой путь расположения файлов тестов - папка Tests.

б) Указать путь к файлу результатов- папка ResultTesting.

в) Отметить "галочки" Блокировать попытки обмана программы и Помечать попытки обмана словом ...(ввести удобное... слово).

г) Отметить "галочку" запись/чтение результата от имени.

д) В полях Пользователь,Пароль,Домен ввести данные учетной записи Windows Преподавателя.

8. Войти в Windows как "Студент" и создать ярлык на рабочем столе со ссылкой на программу TestingV3.exe. Запустить программу и зайти в "Параметры".

9. Нажать кнопку "Проверить" - если проверка прошла успешно(сообщение об успешной записи) см. следующий пункт, если было выдано сообщение об ошибке, то необходимо еще раз пройтись по пунктам, начиная с 1 и корректно выставить параметры.

10. Нажать кнопку "Безопасный просмотр результатов" - при корректных настройках Вы увидите файл результатов с "Тестовой записью".

11. Сменить пароль используемый по умолчанию.

Возможность просмотра результатов во время тестирования:

Эта возможность доступна с любого клиента и вызывается нажатием на кнопку "Безопасный просмотр результатов" в разделе Параметры. Рекомендуется до окончания тестирования использовать эту кнопку, т.к. это безопасно.


Параметры

С помощью кнопки Параметры возможно выбрать путь к папке тестов, задать требуемый путь к файлу результатов, сменить пароль защиты файла результатов.

В качестве путей можно выбирать как локальные так и сетевые папки.

"Блокировать попытки обмана программы" - данный переключатель (во включенном состоянии) позволяет не допускать изменения стратегически важных данных в памяти. Если он выключен, то программа не будет препятствовать изменению данных, но возможно их обнаружит(см. следующий переключатель).

"Помечать попытки обмана программы словом ..." - Если переключатель включен, то в файле результатов, при обнаружении модификации данных, в колонке "Комментарий" появится заданное слово.

"Запись/Чтение результата от имени ..." -используется, когда необходимо изолировать результаты тестирования от тестируемого. Более подробно см. Порядок работы и Порядок работы в сети .

"Безопасный просмотр результатов" -эта кнопка должна использоваться при работе в сети, для безопасного просмотра результатов во время тестирования.


Безопасность

Для обеспечения безопасности и сохранности файла результатов разработчик рекомендует соблюдать следующие правила:

1. После сообщения преподавателю начального пароля защиты он должен сменить пароль на требуемый и держать его в строжайшей тайне.

2. Следовать инструкциям по настройке безопасности и общего доступа Порядок работы и Порядок работы в сети .


Авторы

 Top Previous

Разработчики программы:

Разуванов Александр, Курзенков Сергей, Радюк Павел.

Обратная связь:

testing@baa.by

Техническая поддержка:

При возникновении проблем можно написать по адресу testing@baa.by при этом как можно точнее описать проблему и, возможно, вложить в письмо проблемный тест. Необходимо отметить, что если вы пришлете тест в котором при автоматической проверке содержится "куча" ошибок, то авторы оставляют за собой право не ответить на письмо.