MyTestX - компьютерное тестирование знаний

MyTest X- система программ для создания и проведения компьютерного тестирования, сбора и анализа их результатов

КРАТКОЕ СПРАВОЧНОЕ РУКОВОДСТВО ПО ПРОГРАММЕ

MyTest X это - система программ

MyTest X это - система программ (программа тестирования учащихся, редактор тестов и журнал результатов) для создания и проведения компьютерного тестирования, сбора и анализа результатов, выставления оценки по указанной в тесте шкале.

Программа MyTest X работает с девятью типами заданий: одиночный выбор, множественный выбор, установление порядка следования, установление соответствия, указание истинности или ложности утверждений, ручной ввод числа (чисел), ручной ввод текста, выбор места на изображении, перестановка букв. Задание типа да/нет легко можно получить, используя тип с одиночным выбором. В тесте можно использовать любое количество любых типов, можно только один, можно и все сразу.

Программа состоит из трех модулей: Модуль тестирования (MyTestStudent), Редактор тестов (MyTestEditor) и Журнал тестирования (MyTestServer). Так же имеется дополнительный модуль MyTestBuilder для создания автономных тестов в формате exe.

Модуль тестирования (MyTestStudent) является "плеером тестов". Он позволяет открыть или получить по сети файл с тестом и пройти тестирование. Ход тестирования, сигнализация об ошибках, способ вывода результата тестирования зависит от параметров теста, заданных в редакторе.

Для создания тестов имеется очень удобный редактор тестов (MyTestEditor) с дружественным интерфейсом. С помощью редактора можно создать либо новый тест, либо изменить существующий. Так же в редакторе настраивается процесс тестирования: порядок заданий и вариантов, ограничение времени, шкала оценивания и многое другое.

Журнал тестирования (MyTestServer) позволяет организовать тестирование более удобным образом. С помощью него можно раздавать файлы с тестами по сети, получать результаты со всех компьютеров тестируемых и анализировать их в удобном виде.

В программе имеются богатые возможности форматирования текста вопросов и вариантов ответа. Вы можете определить шрифт, цвет символов и фона, использовать верхний и нижний индекс, разбивать текст на абзацы и применять к ним расширенное форматирование, использовать списки, вставлять рисунки и формулы...

Программа поддерживает несколько независимых друг от друга режимов: обучающий, штрафной, свободный и монопольный. В обучающем режиме тестируемому выводятся сообщения об его ошибках, может быть показано вступление и объяснение к заданию. В штрафном режиме за неверные ответы у тестируемого отнимаются баллы и можно пропустить задания (баллы не прибавляются и не отнимаются). В свободном режиме тестируемый может отвечать на вопросы в любой последовательности, переходить (возвращаться) к любому вопросу самостоятельно. В монопольном режиме окно программы занимает весь экран и его невозможно свернуть.

Параметры тестирования, задания, звуки и изображения к заданиям для каждого отдельного теста - все хранится в одном файле теста. Никаких баз данных, никаких лишних файлов – один тест – один файл. Файл с тестом зашифрован и сжат.

С помощью программ MyTest X вы можете организовать как локальное так и сетевое тестирование. При сетевом тестировании результаты тестирования могут быть переданы по сети в модуль Журнал, а могут быть отправлены по электронной почте.

Размер установочного файла с программой менее 3 Мбайт, а вместе со справкой, образцами тестов, около 5 МБайт (зависти от количества тестов в комплекте).

При невозможности провести компьютерное тестирование из электронного теста можно быстро сформировать и распечатать "бумажный" тест.

Автор программы: Башлаков Александр Сергеевич.

Программа доступна на пяти языках: русском, украинском (перевод Сосновцев Александр), белорусском (перевод Федор Веренич), английском (перевод Дмитрий Никитин) и монгольском (перевод Bekbolat Khalik).

Подробности о возможностях программы и способах их применения смотрите в соответствующих разделах.

Внимание! Более подробная информация о программе, иллюстрации, видеоматериалы, тесты находится на сайте программы MyTestX по адресу mytest.klyaksa.net в вики-разделе.

Справочная информация

Общая информация:

  • Тесты MyTest
  • Типы заданий

Модули программы MyTest:

  • Модуль тестирования
  • Редактор тестов
  • Журнал тестирования

Установка и настройка:

  • Установка программы MyTest
  • Установка MyTest и использование MyTest для "сетевого тестирования"
  • Настройка MyTestStudent

Правовая информация:

  • Лицензия на использование и распространение программы
  • Поддержать развитие программы

  • ЧАВО (часто задаваемые вопросы)
  • Используются

В рамках проекта www.klyaksa.net - информатика и ИКТ в современной школе


Настройка MyTestStudent

Настройка MyTestStudent

Настройка модуля тестирования MyTest X производится либо с помощью меню "Настройка" окна модуля тестирования, либо редактированием файла настроек MyTestStudent_Config.ini (файл сохранен в кодировке UTF8) в обычном текстовом редакторе (например, в Блокноте).

Почти все настройки хранятся в указанном выше файле, реестр ОС Windows не используется, что облегчает перенос программы/настроек на другой компьютер. Т.е. достаточно настроить один раз и скопировать на все компьютеры вашего класса. В реестре хранится только пароль доступа к настройкам, поэтому, если вам это необходимо, ограничивать доступ к настройкам через меню нужно для каждого пользователя компьютера (компьютеров).

Внимание! Настройки прохождения теста (ограничение времени, порядок заданий/вариантов, режим ...) задаются в редакторе тестов MyTest X и хранятся в самом тесте. В меню настройки задаются только параметры работы самой программы тестирования. Следовательно, как будет проходить работа зависит от параметров теста (в первую очередь) и параметров настройки программы.

В меню Настройка модуля тестирования находятся пункты: масштаб, панель инструментов и параметры.

Пункт "Масштаб" позволяет изменять масштаб отображения текста задания и вариантов ответа. Если в тексте имеются картинки или формулы, то они тоже увеличиваются или уменьшаются. Для более комфортной работы пользователь может как увеличить, так и уменьшить его. Эта настройка используется до закрытия программы и не сохраняется в файл.

Пункт "Панель инструментов" позволяет включить или выключить показ панели с кнопками открыть, получить, начать, закрыть тест и другими. Эта настройка сохраняется в файл настроек.

Для их изменения настроек программы воспользуйтесь меню Настройка → Параметры. Окно параметров содержит несколько вкладок на каждой из которой настраиваются определенные параметры.

Пункт "Использовать настройки окна" позволяет включить сохранение текущего размера окна и положение линии разделения текста задания и вариантов.

Для того чтобы настройки использовались не до закрытия модуля, а и при следующем запуске их нужно сохранить. Для этого используйте кнопку "Сохранить настройки сейчас" на вкладке "Сохр. параметры". Так же настройки могут сохраняться автоматически при завершении работы программы, если включен пункт "Сохранять настройки при выходе".

Вы можете выполнить следующие настройки:

  • вкладка Ассоциация

Для того чтобы файлы открывались двойным щелчком Вы можете ассоциировать расширения тестов MyTest (*.mtf) с программой. Для выполнения этого действия требуются права администратора компьютера. Ассоциацию достаточно выполнить только один раз. После этого, при двойном щелчке по файлу с тестом, будет запускаться модуль тестирования MyTestStudent и в нем открываться указанный файл. Поставьте галочку "Ассоциировать файлы ..." и нажмите кнопку Сохранить. Кстати, возможно, что при установке программы вы уже автоматически ассоциировали файлы и проводить данные действия уже не требуется.

Примечание: учитывайте, что одновременно может работать только одна копия модуля тестирования.

  • вкладка Ярлыки

Вы можете создать ярлыки для запуска программы с рабочего стола или меню "Пуск". Тогда файлы можно будет запускать программу проще и быстрее. Для выполнения этого действия требуются права администратора компьютера. Отметьте места где вы желаете создать ярлыки (на Рабочем столе, в меню "Пуск") и нажмите кнопку Сохранить. Ярлыки будут созданы и вам об этом будет выведено сообщение. Дальнейший запуск программы можно производить с помощью ярлыков.

Примечание: а) при перемещении папки с программой (или просто выполняемых файлов модулей программы) ярлыки необходимо будет создать заново; б) создавать ярлыки можно и обычным способом операционной системы Windows.

Кстати, возможно, что при установке программы вы уже автоматически создали нужные ярлыки и проводить данные действия уже не требуется.

  • вкладка Цвета

Вы можете указать цвета которыми будут выделены верные и ошибочные ответы в обучающем режиме тестирования и цвета указания соответствия.

  • вкладка Звук

После окончания теста может воспроизводится звук. Вы можете указать воспроизводить звук по умолчанию или выбрать звуковой файл сами. Для проверки звучания используйте кнопку "Проба".

  • вкладка Папки и файлы

Закладка "Папки" позволяет вам указать программе:

1) Какая папка будут открываться по умолчанию при открытии теста (по умолчанию - папка из которой открывался последний тест). Удобно использовать, если все тесты находятся в одной определенной папке (либо на компьютере, либо в сети);

2) В какой папке будут сохранятся результаты тестирования (по умолчанию - папка с программой).

3) Имя файла для результата в текстовом формате.

4) Префикс для имени файла защищенных результатов.

  • вкладка Пароль

Вы можете ограничить доступ к окну дополнительных настроек задав пароль. Внимание! Не забудьте записать пароль.

  • вкладка Вывод рез.

Вы можете отключить какие-то возможности вывода результатов пользователю. Эти параметры только отключают разрешенные в тесте. Т.е. если в тесте задано сохранять результаты, то вы можете данным образом только отключить эту возможность, включить же, если в тесте она выключена не возможно. Подробнее смотрите в разделе защита теста.

  • вкладка Сеть

Результаты прохождения теста могут быть отправлены учителю на сервер. Так же с сервера тестируемым могут быть получены тесты. Сервер - это компьютер учителя, точнее тот компьютер, где будет запущен модуль журнала.

На компьютере ученика необходимо указать IP-адрес или имя сервера и порт. Например, IP: 192.168.3.11 (или - имя: PC11), порт: 5005. Изменять порт без необходимости не требуется. Если же порт занят другой программой или сервисом, то можете указать другой, но не забудьте так же изменить настройки для журнала (см. журнал тестирования MyTest X).

Для приема результатов на сервере необходимо запустить модуль Журнала MyTest X. Кстати, он называется MyTestServer.

Примечание: для работы Журнала не требуется выделенный сервер в сети или какой-то особенный компьютер, модуль Журнала тестирования может работать на любом компьютере в вашей сети.

Для отправки результатов используется протокол Интернета TCP/IP. Следовательно вы можете организовать тестирование не только в одном классе, но и по всей школе или даже в более крупных масштабах (используя локальную сеть) или Интернет.

Для проверки работы программы (знакомства с программой на одном компьютере) укажите IP-адрес равным 127.0.0.1 (по умолчанию настроено именно так) или имя localhost - т.е. отсылать результаты самому себе. Для реальной работы не забудьте указать нужный IP-адрес или имя компьютера в сети.

Внимание! При использовании в сети Firewall может потребоваться его настройка (разрешение для работы программы на таком-то порту). Например, при первом запуске журнала может потребоваться разрешить работу программы в сети. Нажмите "Разблокировать" и работайте.

Пункт "Пытаться загрузить тест с сервера при старте" служит для включения автоматической загрузке теста по сети. Включение этого пункта аналогично тому, что тестируемый после запуска модуля тестирования щелкает Файл - Получить по сети. Для того чтобы опция была активна должна быть активна "Отправлять результаты учителю, получать тесты".

  • вкладка Email

Результаты прохождения теста могут быть отправлены по электронной почте. Укажите настройки почтового сервера.

  • вкладка Имя

Вы можете указать какую информацию (имя, класс, группу) необходимо вводить пользователю в окне начала теста. Можно просто указать заголовок полей ввода, значения по-умолчанию, шаблон для проверки введенных данных. Шаблоны задаются на основе регулярных выражений. В настройках по умолчанию есть пример. Можно отключить использование шаблонов - не задав его. В настройках по умолчанию:

Шаблон имени: ^[А-Я]{1}[а-я]{1,} [А-Я]{1}[а-я]{1,}$ - подходят имена из русских букв, причем первые буквы должны быть большими. Например, Иванов Иван. Лишнее пробелы в имени программа удаляет сама.

Шаблон класса: ^[1-9]{1}[0-1]{0,1} [А-Яа-я]{1}$ - начинается с цифры от 1 до 9, затем может идти еще 0 или 1 ... пробел ... большая или маленькая русская буква. Например: 10 А. Подробнее с регулярными выражениями можно познакомиться, например, на Wikipedia тут, и тут. Что бы пользователь понимал как вводить имя группу при использовании шаблонов ввода есть поле образец.

  • вкладка Список

Имя тестируемого и его группа или класс могут выбираться из списка. Если эта опция выключена, то эти данные пользователи вводят вручную (обычный вход).

  • вкладка Сохр. параметров

Все изменения действуют до перезагрузки программы. Для их автоматического или ручного сохранения используете эту вкладку.

Для сброса всех настроек (кроме пароля к окну Дополнительные настройки) достаточно удалить файл настроек. Позже он будет создан (при необходимости) программой заново.

См. также:

  • Установка программы MyTest
  • Установка MyTest и использование MyTest для "сетевого тестирования"
  • Настройка MyTestStudent


Поддержать развитие программы

Поддержать развитие программы

Разместить кнопку программы

Если вам понравилась программа и у вас есть свой или школьный сайт разместите, пожалуйста, кнопку программы:

Для этого просто скопируйте приведенный ниже HTML-код и вставьте на свою страничку.

<a href="http://mytest.klyaksa.net">
<img src="http://mytest.klyaksa.net/images/mytest_88_31.gif" width="88" height="31"
style="border: 1px solid #C0C0C0" alt="MyTest" title="Компьютерное тестирование">
</a>

Принять участие в создании справки

Вы можете упростить жизнь тех, кто только знакомится с программой. Для этого примите участие в создании справочной системы. Из-за спама многие страницы защищены от изменений, в этом случае оставляйте свое сообщение (что хотели добавить или изменить) в обсуждении страницы.

Рассказать другим о программе

Вы можете рассказать своим друзьям и коллегам о программе, помочь сделать им первые шаги в ее освоении. Причем это можно делать и offline, и online (в форумах, конференциях...).

Помочь финансово

Программа MyTest X распространяется бесплатно (и бесплатна для некоммерческого использования). Любое государственное образовательное учреждение, учитель и ученик могут бесплатно использовать программу на основе лицензионного соглашения без каких либо денежных отчислений.

Но на развитие и поддержку программы у автора уходит много свободного времени, которое он мог бы потратить на зарабатывание денег или отдых.

Если у вас есть возможность автор будет рад вашему пожертвованию. Вы можете перевести любую сумму на кошелек автора в системе Яндекс.Деньги 41001266143925 или на WebMoney R383556294822, Z344134432441.

Спасибо.


Редактор тестов

Редактор тестов

Для создания тестов в программе имеется удобный редактор тестов. Имя файла редактора тестов: MyTestEditor.exe.

С помощью редактора можно создать либо новый тест, либо изменить существующий. Так же в редакторе настраивается процесс тестирования: порядок заданий и вариантов, ограничение времени, шкала оценивания и многое другое.

Интерфейс и работа с заданиями

В редакторе вы можете редактировать задания и сразу же видеть их почти так как увидит ученик. Интуитивно понятный интерфейс позволит Вам быстро создать или изменить тест.

С левой стороны окна редактора располагается список заданий. Иконки в этом списке характеризуют тип задания. Для добавления, удаления, перемещения, изменения типа задания и т.п. служат команды пункта меню "Задание", панель инструментов и соответствующие сочетания клавиш. При соответствующих настройках и наличия в тесте двух и более тем (групп) заданий задания той же темы, что и редактируемое, выделяются цветом.

Если необходимо выделить несколько заданий в списке, то это можно сделать либо щелкая по заданиям с нажатой клавишей Ctrl или Shift, либо с помощью окна, которое открывается по команде Параметры заданий - Выделить задания...

Для изменения некоторых параметров (сложность, время, шрифт) всех выделенных заданий сразу, сортировки или поиска заданий можно использовать либо команды меню Параметры заданий, либо контекстное меню списка заданий.

В любой момент можно изменить содержание, тип заданий, порядок заданий в тесте. Количество заданий в тесте не ограничено.

При выборе какого-либо задания из списка его содержимое отображается в рабочей области окна Редактора тестов. Рабочая область окна содержит три вкладки: Основное (содержит основной текст вопроса, рисунок и варианты ответов), Формулировки (содержит все формулировки вопроса) и Дополнительно (содержит вступление, подсказку, объяснение ответа и другое).

Введите или измените текст вопроса, вариантов, выберите, если необходимо, рисунок к заданию... Для сохранения изменений в задании нажмите кнопку "Сохранить задание". Эта кнопка активна только тогда, когда были произведены изменения в выбранном задании. При переходе к другому заданию, если текущее не сохранено, программа предложить его сохранить.

По-умолчанию программа предлагает пять вариантов ответа (для заданий со списком вариантов), но это не означает, что вы должны использовать ровно пять вариантов. Если вам достаточно три или четыре варианта не вводите ничего в поле ненужного варианта, задайте текст только нужных вариантов. Если вам нужно больше вариантов, чем показано, воспользуйтесь кнопкой "Добавить еще вариант ответа". Таким образом в задании может быть от 1 до 10 вариантов. Их реальное количество программа определит сама. В задании на ручной ввод числа по-умолчанию предлагается один вариант ответа, но вы аналогичным образом можете использовать от одного до пяти вариантов.

Можно изменять порядок заданий (используя перетаскивание или команды меню Задания), добавлять и удалять задания, дублировать, копировать в буфер обмена и вставлять, изменять тип... Для этого используются либо кнопки панели инструментов, либо меню Задание. С помощью меню "Параметры заданий" можно сортировать задания по различным признакам (типу, сложности..).

При редактировании текстов вопроса и вариантов ответа в задании можно выполнять операции копирования, вырезания, вставки. Для этого либо используйте стандартные комбинации клавиш (Ctrl + C, Ctrl + X, Ctrl + V), либо контекстное меню (щелчок правой кнопкой мыши) поля ввода текста.

Вы можете форматировать текст вопроса и вариантов задания. Простейшие операции доступны либо через комбинации клавиш, либо через контекстное меню. Так же в программе имеется небольшой, но удобный текстовый редактор. Текстовый редактор вызывается либо через меню "Текст", либо через контекстное меню текстового поля (пункт Открыть текстовый редактор), либо горячей клавишей F10. Если в редактируемом текстовом поле выделен какой-то текст, то в открывшемся окне текстового редактора он тоже будет выделен. В текстовом редакторе вы можете не только редактировать и форматировать текст, но и вставлять различные объекты (рисунки, формулы).

Так же вы можете редактировать и форматировать текст в своем любимом текстовом редакторе (например, Word) и вставлять его в программу.

К каждому заданию можно прикрепить рисунок, который будет показан в отдельном окне (удобно для больших рисунков). При сохранении теста, если в нем используются изображения программа сохраняет их в один файл с тестом. При этом, если вы несколько раз используете один и тот же рисунок, то размеры файла не увеличиваются.

К каждому заданию так же можно прикрепить звуковой файл в формате wav или mp3. Соответствующие кнопки находятся на вкладке Дополнительно, внизу окна. Прикрепляя звуковой файл учитывайте, что все звуковые файлы будут сохранены в тесте и значительно увеличат его объем, так же для воспроизведения mp3 файлов на компьютере должны быть установлены соответствующие кодеки.

Настройка параметров теста

Параметры теста можно настроить через одноименное меню Параметры теста или с помощью панели параметров теста. Вы можете задать

  • автора теста
  • заголовок и описание теста
  • инструкцию тестируемому
  • заметки к тесту
  • порядок следования заданий и вариантов (в заданиях в несколькими вариантами)
  • используемую формулировку вопроса
  • изменить способ оценивания или добавить свою систему оценки
  • создать и настроить темы (группы) заданий, задать ограничение на количество задаваемых заданий (т.е. делать выборку из имеющихся)
  • ограничение времени и количества запусков программы без перезагрузки
  • пароли для открытия, редактирования файла, начала тестирования, открытия защищенных результатов
  • параметры вывода результата тестирования, записи результатов в файл и отправки по сети
  • и другие параметры...

При выборе некоторых пунктов будут открываться дополнительные окна, где вы можете ввести текст или другие данные.

В строке состояния Редактора присутствуют индикаторы значений некоторых параметров (порядок заданий и вариантов, включенные режимы). Например, если в строке состояния подсвечиваются О и ЗС, то включен обучающий режим и случайный порядок заданий.

Параметры оценивания.

Когда вы создаете новый тест и добавляете несколько заданий, то он уже, практически, готов к использованию. Но в нем заданы параметры по-умолчанию. В том числе и параметры оценивания. Система оценки по-умолчанию пятибальная (на "5" - от 85%, на "4" - от 70%, на "3" - от 50%, такая шкала наиболее часто рекомендуется в методической литературе по оцениванию тестов в школе). Но, если вас не устраивает данная шкала оценки, или в вашей школе используется, например, двенадцатибальная система оценки, то вы можете ее изменить дав команду Параметры теста - Оценивание...

В открывшемся окне, для удобства вы можете выбрать одну из готовых шкал оценивания или создать свою. Система оценивания может быть от 2-х балльной до 100 балльной. Для каждого балла шкалы вам необходимо указать минимальный процент полученных за тест баллов (очков) для получения данной отметки. Если требуется, то каждого балла можно задать название, которое заменит цифровую отметку.

Темы (группы) заданий.

Каждое задание теста относится к какой-то теме (группе). Когда вы создаете тест в нем уже есть одна тема по-умолчанию и все созданные задания будут относится к ней. Зачем нужны эти темы? Темы заданий предназначены для удобного разделения заданий на группы и ограничения количества заданий для ученика. Вы можете указать, сколько именно заданий из какой темы будет задано. При ограничении количества заданий они выбираются случайным образом.

Для изменения, добавления, удаления и т.п. тем дайте команду Параметры теста - Редактор тем (групп)... Для изменения темы её нужно выбрать и нажать кнопку Редактировать (или просто выбрать двойным щелчком). Поля вверху окна станут активными и вы сможете изменить параметры этой темы.

Если вы задали ограничение количества заданий по темам и желаете применить эти параметры при раздаче заданий тестируемым, то поставьте галочку внизу окна "Использовать ограничение количества заданий по темам при выборе заданий для тестирования". Если эта галочка не стоит, то будут заданы все задания из теста.

Некоторые комбинация клавиш

Для заданий:

Кнопки Вверх и Вниз позволяют перемещаться по списку заданий.

Alt + Ins - добавить задание. Появится окно выбора типа задания, выберите нужный и нажмите кнопку ОК. Аналогично щелку по пункту "Добавить...".

Alt + 1 (2, 3, ... 9)- добавить задание соответствующего типа. Аналогично двойному щелку по пункту "Добавить" и выбора типа задания.

Alt + 0 - добавить задание с одиночным выбором и уже введенными значениями Да и Нет.

Alt + Del - удаление выбранного задания.

Alt + C - копировать задание в буфер обмена.

Alt + V - вставить задание из буфера обмена.

Alt + F - поиск задания по тексту.

Для текста вопроса и вариантов:

Ctrl + Z - отменить последнюю операцию редактирования/форматирования текста;

Ctrl + C - копировать текст;

Ctrl + X - вырезать текст;

Ctrl + V - вставить текст;

Ctrl + B - жирное начертание текста;

Ctrl + I - наклонное начертание текста;

Ctrl + U - подчеркивание текста;

F10 - открыть встроенный текстовый редактор (для редактирования и форматирования текста, вставка рисунков и формул).

Добавление заданий из другого теста

С помощью команды Файл → Импорт → Задания из другого теста... вы можете добавить в создаваемый/редактируемый тест задания из любого другого теста. При добавлении заданий вы можете выбрать какие именно задания добавить (отметить галочками), указать добавлять ли в этот тест темы из исходного ...

Создание бумажных тестов

В редакторе тестов вы можете их экспортировать для печати. При экспорте можно либо просто вывести все задания, либо вывести задания так как они бы были выведены тестируемому (т.е. учитывая ограничение количества по темам, порядок заданий, порядок вариантов). Дополнительно можно вывести и верные ответы.

Для этого используйте команду Файл → Экспорт → Бумажный тест. Будет открыто окно встроенного редактора и в нем созданный текст. Этот тест можно либо сразу распечатать, либо сохранить в файл, а затем открыть в вашем любимом текстовом редакторе (Microsoft Office Word или OpenOffice.org Writer).

Полезные мелочи:

Двойной щелчок по полю "Ограничение по времени" вызывает окно, где отдельно настраиваются часы, минуты и секунды. Двойной щелчок по команде меню Задание → Добавить (там появляется подменю с типами) сразу добавляет задание с одиночным выбором. Для задания всем заданиям одинаковых значений сложности, ограничения по времени используйте пункты меню Параметры заданий. После создания теста рекомендуется проверить его, вдруг где-то забыли указать ответ и т.д. Для этого используйте команды Параметры заданий → Проверить все (или Проверить выбранное).

См. также:

  • Модуль тестирования
  • Редактор тестов
  • Журнал тестирования


ЧАВО

ЧАВО

ЧАВО - это часто задаваемые вопросы

В: Сколько вопросов может быть в тесте?

О: Количество вопросов (заданий) в тесте неограниченно.

В: Сколько может быть вариантов ответа в задании?

О: Программа поддерживает большое число типов заданий. В заданиях с набором вариантов для ответа (одиночный или множественный выбор, установление порядка, сопоставление, указание истинности) может быть до 10 (включительно) вариантов ответа. В заданиях на ввод числа до 5 (включительно).

В: В редакторе я вижу только 5 вариантов ответа. Как добавить еще?

О: Ниже кнопочка Добавить еще вариант ответа.

В: Мне нужно всего 3 или 4 варианта ответа, а их 5. Как убрать лишние?

О: Не заполняйте их и они не будут использоваться (будут не активны).

В: Как открыть файл с тестом?

О: Можно использовать разные способы: 1) Запустите программу (MyTestStudent - для тестирования, MyTestEditor - для редактирования тестов) и дайте команду Файл - Открыть. Выберите нужный файл с тестом и откройте его. 2) Перетащите файл с тестом на окно программы - он откроется (исключение если в MyTestStudent уже открыть другой тест). 3)Настройте ассоциацию расширения файла с тестом с программой. Тогда тесты для тестирования открываться двойным щелчком по файлу, а для редактирования правой кнопкой и команду изменить. Настраивается это все в окне Дополнительные настройки или при установке программы с помощью инсталлятора.

В: Не могли бы вы выслать мне исходный код вашей программы?

О: Исходные коды программы никому не высылаются.

В: Сколько стоит программа MyTest X.

О: Для некоммерческого использования программа MyTest X совершенна бесплатна. Т.е. вы и ваши ученики, на основе лицензионного соглашения, могут использовать ее абсолютно законно и дома и в школе бесплатно. Стоимость коммерческого использования можно узнать на сайте или по электронной почте у автора.

В: Я задал пароль для теста и забыл его. Как его восстановить?

О: С электронного адреса указанного в параметрах теста (эл. адреса автора) отправить файл и запрос на адрес автора программы (он есть в окне О программе). Пароль можно получить тоже только на указанный в тесте адрес. Цена восстановления пароля договорная (от 100 руб).

В: Как настроить тестирование так, чтобы задавались не все вопросы, а только их часть?

О: В редакторе тестов откройте окно Параметры теста - Редактор тем (групп)... Вы можете указать сколько заданий задать. Для удобства задания можно разбить на разные темы (группы) и ограничить количество заданий из каждой группы по отдельности. При использовании ограничения не забудьте поставить птичку (использовать ограничение количества) внизу этого окна.

В: Я настроил программу для сетевого тестирования, но результатов не получил. Почему?

О: Проверьте, может вы забыли запустить модуль Журнал на компьютере Учителя. Не помогло - проверьте настройки программы, проверьте связь с сервером.


Лицензия на использование и расп

Лицензия на использование и распространение программы

1. Лицензия

Настоящее Лицензионное соглашение («Лицензия») заключено между Вами, пользователем («Пользователь»), и автором программы Башлаковым Александром Сергеевичем,

РФ, 243300, Брянская обл., г. Унеча, являющимся правообладателем исключительных прав на Программу («Правообладатель»). Лицензия устанавливает условия использования и распространения Пользователем программы для ЭВМ «MyTest X» («Программа»), а также материалов, созданных с использованием Программы.

1.1. Используя, копируя, распространяя Программу, Пользователь выражает свое полное и безоговорочное согласие со всеми условиями Лицензии.

1.2. Если вы не согласны с условиями данной лицензии, то вы должны удалить все файлы Программы со своих устройств хранения информации и отказаться от

дальнейшего использования или распространения этого программного продукта. Любое использование Программы означает полное и безоговорочное принятие Вами условий настоящего лицензионного соглашения.

1.3. Лицензионное соглашение действует на протяжении всего срока использования продукта.

1.4. Лицензионное соглашение действует на территории РФ и всех других государств.

2. Права на Программу

2.1. Исключительное право на Программу принадлежит исключительно Правообладателю.

2.2. В случае нарушения авторских прав предусматривается ответственность в соответствии с действующим законодательством РФ.

3. Права Пользователя

3.1. Правообладатель предоставляет Пользователю неисключительное непередаваемое право (простая лицензия) использовать Программу следующими способами:

3.1.1. Применять Программу по прямому функциональному назначению в некоммерческих целях (безвозмездно), в целях чего произвести ее копирование и установку на персональном(ых) компьютере(ах) Пользователя. Пользователь вправе произвести установку Программы на неограниченное число персональных компьютеров.

3.1.2. Воспроизводить и распространять Программу в некоммерческих целях (безвозмездно). Ни одно частное лицо или организация не вправе брать плату за распространение Программы (как отдельно, так и в составе каких-либо сборников или другого продукта) без письменного разрешения Правообладателя.

3.1.3. Тесты, созданные Пользователем в Программе распространять на любых условиях, не противоречивших Лицензии, как безвозмездно, так и за плату. Исключение составляют автономные тесты, права на распространение автономных тестов такие же, как и на распространение самой программы.

3.1.4. Для коммерческого использования или использования в коммерческих организациях необходимо приобрести соответствующие права.

3.2. Пользователь имеет право, в порядке установленном Правообладателем, зарегистрировать свою копию Программы и получить регистрационный ключ.

3.3. Пользователь имеет право поддержать развитие Программы и отблагодарить Правообладателя способом согласованным с Правообладателем.

4. Ограничения

4.1. Пользователь не имеет права осуществлять и/или разрешать осуществлять в отношении Программы следующие действия: вскрывать технологию, эмулировать, создавать новые версии, изменять, дешифровать, декомпилировать, дизассемблировать, изучать код программы другими способами и производить иные действия с кодом Программы, прямо не предусмотренное настоящей Лицензией без письменного согласия Правообладателя.

4.2. Пользователь не имеет права использовать, воспроизводить, распространять Программу (как отдельно, так и в составе каких-либо сборников или другого продукта) в коммерческих целях (за плату), без письменного согласия Правообладателя.

4.3. Пользователь не имеет права изменять наименование Программы, изменять и/или удалять обозначение авторских прав Правообладателя (copyright).

4.4. При распространении программы обязательным условием является указание авторских прав на Программу, сайта Правообладателя (http://www.klyaksa.net) и сайта программы (http://mytest.klyaksa.net).

4.5. Запрещается распространение и применение программных продуктов, модифицирующих (изменяющих) исходный программный код Программы (за исключением официальных обновлений, выпускаемых Правообладателем).

4.6. Запрещается при регистрации указывать чужие или не верные данные. Запрещается передавать свой регистрационный ключ другим пользователям, кроме Правообладателя.

4.7. Запрещается использование справочных материалов к Программе в коммерческих целях, без письменного согласия Правообладателя.

4.8. Запрещается любое использование Программы, противоречащее действующему законодательству РФ.

5. Ответственность по Лицензии

5.1. Программа предоставляется на условиях «как есть». При этом не предусматривается никаких гарантий, явных или подразумеваемых. Вы используете программу на свой собственный риск. Правообладатель не гарантирует, что она или сопутствующие материалы не содержат ошибок.

5.2. В максимальной степени, допустимой действующим законодательством РФ, Правообладатель не несет никакой ответственности за прямые или косвенные убытки (включая прямой ущерб и неполученную выгоду) причиненные Пользователю и/или третьим сторонам в результате какого-либо применения или не применения программы, в том числе возникшие из-за возможных ошибок или опечаток в её комплекте.

6. Изменения условий настоящей Лицензии

6.1. Настоящее лицензионное соглашение может изменяться Правообладателем в одностороннем порядке.


Журнал тестирования

Журнал тестирования

Журнал (сервер) - модуль программы MyTest, позволяющий централизовано принимать и обрабатывать результаты тестирования, раздавать тесты посредством компьютерной сети. Для отправки и получения результатов, отправки файлов с тестами используется протокол Интернета TCP/IP.

Имя файла редактора тестов: MyTestServer.exe.

Что это дает?

  • Тестирование проходит более спокойно. Учителю нет необходимости перемещаться по классу (школе) для получения результатов.
  • Быстрая подготовка к тестированию, защита тестов от несанкционированного доступа. Учителю не требуется копировать файлы с тестами на компьютеры учеников, тесты можно "раздать" прямо из Журнала.
  • Учитель получает очень подробную информацию об результатах тестирования, а не только одну оценку.
  • Учитель может настроить вид таблицы результатов под себя (скрыть можно любые колонки).
  • Учитель может быстро проанализировать результаты (например, какие вопросы вызвали наибольшие трудности) и сразу же провести работу над ошибками. Есть возможность просмотра диаграмм тестирования и быстрого перехода в Редактор тестов к выбранному заданию.
  • Упорядочить результаты по любому критерию.
  • Учитель может сохранить результаты в файл. Этот файл затем можно открыть и обработать позже.
  • Экспортировать результаты в текстовый файл (для дальнейшего открытия в электронных таблицах) или HTML-файл.
  • Учителю удобно выставлять отметки за тест.
  • ... вы сами сможете продолжить этот список начав использовать программу.

Как это работает?

1. Учитель запускает модуль журнала программы MyTest.

2. Учащиеся запускают программу MyTest и начинают тестирование. Тесты можно открыть либо со своего компьютера, либо из сетевой папки, либо получить по сети от учителя.

3. Как только учащийся начал тестирование (выбрал тест и начал его проходить) учитель получает сообщение об этом.

4. Как только учащийся закончил тестирование учитель получает очень подробную информацию об его результатах.

5. Полученные результаты учитель может проанализировать и/или сохранить в файл.

Окно журнала

Для удобства окно Журнала может сворачиваться в трей (отображаться значком в левом нижнем углу около часов). При получении новых результатов может быть показано всплывающее окошко (в левом нижнем углу) с краткой информацией об результатах.

Окно журнала содержит несколько вкладок: "Результаты", "Монитор", "Сообщения", "Лог", "Раздать список".

На вкладке "Результаты" отображается следующая информация:

  • Дата получения результата;
  • Время получения результата;
  • Сетевое имя компьютера;
  • Имя ученика (которое он вводит при запуске теста);
  • Группа (класс) - дополнительное поле к имени;
  • Оценка;
  • Результат в процентах (100*Кол-во баллов/Кол-во баллов возможно всего);
  • Баллов всего;
  • Баллов набрано.
  • Заданий всего;
  • Заданий задано;
  • Заданий правильно;
  • Заданий ошибочно;
  • Заданий пропущено;
  • Заданий подсказок;
  • Заданий результативность (100*Кол-во правильно/Кол-во заданий отвечено);
  • Время начала теста (по времени на компьютере ученика);
  • Время завершения теста (по времени на компьютере ученика);
  • Время всего теста (не зависимо от времени на компьютере ученика, защищено от изменений системного времени);
  • Заголовок теста;
  • Полное имя файла с тестом;
  • CRC файла с тестом (если ученик подменил или спутал файл с тестом вы сразу это обнаружите по другому значению);
  • UID файла с тестом (при сохранении теста каждому присваивается свой уникальный идентификатор (если ученик подменил или спутал файл с тестом вы сразу это обнаружите по другому значению);
  • Режим окончания теста;
  • Сетевое имя компьютера;
  • IP-адрес компьютера;
  • Имя пользователя компьютера;
  • Маска результатов (Внимание! Не зависимо от порядка выдачи ученику заданий, маска соответствует порядку заданий в файле - как видите в редакторе!);
  • Маска времени;
  • Маска ответов (что ответил ученик на вопросы);
  • Маска подсказок;
  • Примечание.

Какие именно колонки будут отображены вы в любой момент можете задать в настройках Вид - Показывать колонки. Эта настройка может быть сохранена для дальнейшего использования, т.е. при следующем запуске будут показаны выбранные вами колонки.

Ширина колонок может изменятся под данные автоматически, либо вручную. Зависит от пункта Вид - Показывать колонки.

Вы можете изменить содержимое только следующих колонок: Имя, Группа, Примечание. Остальные колонки защищены от правки.

Вы можете отсортировать результаты по любой колонке. Для этого щелкните по ее заголовку. Например, при щелчке по заголовку Оценка строки сгруппируются и отсортируются по этому критерию от меньшего к большему: сначала будут идти двоечники, потом троечники, хорошисты и отличники. Например, при щелчке по заголовку Имя строки упорядочиваются по алфавиту по этому критерию...

На вкладке "Монитор" выводится информация о процессе тестирования. Вы можете видить какие компьютеры (и ученики) выполняют тест (и какой тест) и сколько заданий выполнил ученик (+ сколько из них верно или ошибочно, % результативности), сколько баллов (максимум, возможно было бы набрать за эти ответы, набрано, % пред. результат).

На вкладке "Сообщения" отображается информация об начале или завершении тестирования учениками (например, 21.02.2009 12:11:26 192.168.3.5: Иванов Иван (PC05) начал тест: "Демонстрационный тест №2" (C:\MyTest\ДемоТест_0002.mtf)). Указывается дата и время получения сообщения, имя и IP-адрес компьютера ученика, имя тестирующегося (то которое он ввел при запуске теста).

На вкладке "Лог" выводится служебная информация о запуске сервера, об сообщениях при обмене данными. Предназначена для большего контроля над процессом работы модуля и поиска проблем при работе в сети.

На вкладке "Раздать тест" можно указать какие файлы с тестами будут получать тестируемые по команде Файл - Получить по сети (или автоматически при соответствующей настройке). Эта возможность экономит время учителя - нет необходимости копировать файл на компьютеры учеников. Еще одно преимущество - файл с тестом не сохраняется на компьютерах тестируемых, у них нет возможности открыть его для подсматривания, поэтому не требуется задавать пароли. Если в список для раздачи тестов добавлен только один файл, то ученик при запросе теста (Файл - Получить по сети...) откроет этот файл. Если же в список добавлено несколько файлов, то ученик при запросе теста (Файл - Получить по сети...) увидит окно, предлагающее выбрать какой именно файл он желает получить. После выбора файла из этого списка он будет загружен.

На этой же вкладке отображаются запросы тестируемых за тестами: 21.02.2009 11:30:15 PC02(192.168.3.2): Запрос на получение файла. 21.02.2009 11:30:15 PC02(192.168.3.2): Отправлен тест "C:\MyTest\ДемоТест_0001.mtf".

Если Журнал запущен, но не выбран файл или не стоит галочка "Раздавать файл с тестом", то ученик при команде Файл - Получить по сети получит сообщение об отказе в получении теста.

На вкладке "Раздать список" можно указать файл со списком пользователей (тестируемых). Если в модуле тестирования произведены соответствующие настройки, то пользователь сможет получить этот список и выбрать себя из списка, а не вводить вручную.

Анализ результатов

Помощь в анализе результатов тестирования могут оказать диаграммы и сводные таблицы из меню Анализ.

Для анализа результатов доступны две диаграммы - гистограммы: диаграмма правильности и среднего времени обдумывания. На диаграмме правильности каждому заданию соответствуют две колонки (зеленая - правильно, красная - ошибочно). На диаграмме среднего времени обдумывания - каждому заданию соответствует один столбец.

Диаграмма будет построена для всех тестируемых, которые работали с тем тестом какой у выбранного в Результатах. Т.е. если у вас 5 учеников проходили тест 1, а другие 6 учеников тест 2 и выбран ученик, который проходил тест 2, то для построения диаграммы будут использованы результаты всех этих 6 учеников.

Если запустить Редактор тестов MyTestX и в нем открыть тест для которого построена диаграмма, то щелчок по столбцу диаграммы с одновременным нажатием клавиши Alt, переведет Редактор на передний план и в нем будет выбран соответствующее задание. Эта возможность позволяется удобно проанализировать ошибки и разобрать задания с учениками.

Диаграмму можно как рисунок скопировать в буфер обмена или сохранить в файл.

Если вы используете пятибальную систему оценки, то вам доступно "Качество ЗУН". В этом окне выводится информация: сколько учеников справилось на "5", "4", "3", "2", успеваемость, качество, СОУ, средний балл.

Анализ тестирования по заданиям позволяет получить таблицу столбцы которой соответствуют номерам заданий в тесте, а верхние строчки таблицы каждому ученику, проходившему этот тест, нижние строки общую статистическую информацию по заданиям. Ячейки таблицы выделяются различными цветами в зависимости от значений этой ячейки и/или строки. Это позволяет более быстро проанализировать результаты.

Так же как и диаграммы, из таблицы анализа по заданиям можно быстро перейти в Редактор тестов к соответствующему заданию. Для этого удерживая клавишу ALT щелкнуть по нужному столбцу таблицы. Естественно, предварительно нужно запустить Редактор тестов и открыть соответствующий файл с тестом.

Анализ тестирования по темам позволяет узнать результативность по каждой теме (группе заданий) теста. Каждая строка таблицы соответствует отдельной теме в тесте. Таким образом можно выяснить, например, задания каких тем вызывают наибольшие трудности у учащихся и скорректировать процесс обучения. Естественно данный анализ имеет смысл если вы используете распределение заданий по темам.

Оба указанных выше анализа можно проводить как для одного отдельного ученика, так и для всех учеников, проходивших тот же тест.

Протокол тестирования

Для выдачи тестируемому вы можете создать и затем выложить в интернет или распечатать протокол тестирования. Протокол создается на основе шаблона, который вы можете настроить для себя - полностью изменить внешний вид, видимость и порядок каких-либо полей. Шаблон и протокол имеют формат HTML - наиболее простой и универсальный. Команда для создания протокола находится в меню Экспорт результатов.

Экспорт результатов

Результаты, полученные модулем Журнал, вы можете сохранить в файл для последующей работы с ними. Так же для удобства можно экспортировать результаты тестирования либо в html-файл, либо в текстовый файл ...

Экспорт в html-файл удобен для того чтобы вывесить результаты в Интернет, или просто просмотреть их потом с помощью браузера.

Экспорт в текстовый файл (с разделителями табуляции) удобен для импорта результатов в электронные таблицы. Причем, не важно какая именно у вас программа электронных таблиц (Microsoft Excel 98, xp, 2003, 2007 или OpenOffice.org Calc) - все они откроют файл и верно его отобразят. Поэтому отпадает необходимость делать экспорт в каждую версию электронных таблиц.

Копирование результатов

Результаты тестирования можно не только сохранить в TXT или HTML файл, но и скопировать из таблицы в буфер обмена. Для этого выделите нужные ячейки (можно и всю таблицу) и нажмите комбинацию клавиш Ctrl + C или дайте команду Копировать выд. результат как текст из меню Вид. Затем эти данные можно вставить в электронных таблицах или в каком-либо текстовом редакторе.

Импорт результатов

Вы можете добавить в открытый или только что созданный файл результаты из других файлов с результатами. Импортировать можно как обычные результаты, например, те что вы сохранили ранее, так и защищенные результаты. При импорте защищенных результатов, возможно, потребуется ввести пароль (этот пароль для теста задается в редакторе). При открытии защищенных результатов одного и того же теста из нескольких файлов (например, защищенные результаты с ученических компьютеров) пароль требуется ввести только один раз.

Откуда берутся защ. результаты? При соответствующих настройках теста и модуля тестирования, после окончания тестирования результат может быть не только показан тестируемому, отправлен напрямую в модуль Журнал тестирования или сохранен в текстовом виде (все результаты в одном файле), но и либо сохранен в файл защищенных результатов (для каждого теста отдельный файл, который недоступен для правки, а доступен только для импорта в Журнал и может быть защищен паролем), либо отправлены по электронной почте (в этом случае текст письма содержит результаты в текстовом виде, а вложенный файл представляет собой защ. результаты).

Просмотр результатов по сети

Если требуется, можно дать возможность просмотреть результаты тестирования из Журнала по сети с помощью браузера. Для этого в Журнале надо включить http-результаты старт. После этого на любом компьютере в браузере пишем адрес http://имя_сервера:порт (например, http://server:777). В результате в окне браузера открывается страница с результатами из журнала.

Требования к компьютерам и сети

Для работы Журнала не нужен выделенный сервер в вашем классе или какой-то особенный компьютер. Журнал может работать на любом компьютере вашего класса. Естественно, компьютеры должны быть соединены в компьютерную сеть. Так же вид адресации (динамическая или статическая) компьютеров в сети вашего класса не имеет значения. Вы можете задать на какой компьютер будут отправляться результаты указав либо IP-адрес компьютера, либо сетевое имя компьютера. Например, 192.168.1.11 (- IP-адрес компьютера учителя в нашей школе) или PC11 (- имя компьютера учителя в нашей школе)) .

Если компьютер ученика не может связаться с компьютером, указанным в настройках сети, то при отправке сообщений и результатов появится предупреждение об ошибке: "Сервер не найден". В этом случае проверьте настройки программы, работу вашей сети или запущен ли Журнал.

Обратите внимание: для того чтобы учитель смог получить результаты тестирования от учеников необходимо чтобы модуль Журнал был уже запущен и работал во время тестирования (и его окончания). Если же его запустить после тестирования никаких результатов там не окажется - откуда им взяться? Вроде бы все просто и логично, но это наиболее встречающаяся ошибка начинающих пользователей программы.

Так как для отправки и получения результатов используется протокол Интернета TCP/IP, то можно организовать тестирование не только в локальной сети, но и через Интернет. Для этого необходимо, чтобы из Интернета был доступен ваш компьютер (для решения этой задачи обращайтесь к своему провайдеру и сетевому администратору).

См. также:

  • Модуль тестирования
  • Редактор тестов
  • Журнал тестирования


Установка программы MyTest

Установка программы MyTest

Программа MyTestX доступна в двух вариантах - в виде инсталлятора и в виде архива.

Версия с инсталлятором - самый лучший и надёжный выбор для начинающего пользователя. Всё что вам нужно - скачать файл, и запустить его, после этого процесс установки произойдёт без вашего вмешательства. Инсталлятор поможет вам легко установить программу, а также создать ярлыки, ассоциировать файлы, указать нужный язык интерфейса...

Архив программы предназначен для тех, у кого специальные потребности при установке, недостаточно прав для администрирования, или просто для тех, кому не нравятся инсталляторы. В архиве запакованы все нужные файлы, которые просто достаточно распаковать архиватором.

Установка программы с помощью инсталлятора

Внимание! Для установки программы требуются права администрирования.

Процесс установки состоит из нескольких шагов:

Язык установки

Вам будет предоставлен выбор языка установки, выберите его из списка. Нажмите «OK», чтобы продолжить.

Лицензионное соглашение

На этом этапе вы должны наблюдать окно, где вам следует принять лицензионное соглашение, чтобы продолжить. Прочитайте его текст, выберите «Я принимаю условия соглашения» и нажмите Далее, если вы действительно согласны.

Место для установки

В следующем окне вам следует выбрать место для установки программы. Нажмите «Продолжить», если вас устраивает стандартный вариант места для установки.

Выбор компонентов

На следующем этапе вам нужно выбрать компоненты программы, которые вы хотите установить. Для большинства пользователей подходит вариант «Полная установка».

Ярлыки в меню "Пуск"

Вам будет задан вопрос о названии папки в меню для расположения ярлыков. Название по умолчанию вполне может вас устроить, нажмите «Далее», если это действительно так. На этом этапе вы также можете отменить установку этих ярлыков.

Дополнительные задачи

Выберите дополнительные задачи, которые должны выполниться при установке MyTestX, после этого нажмите «Далее». У вас есть возможность создать ярлыки на Рабочем столе, ассоциировать файлы с программой, указать папку для демонстрационных тестов, выбрать язык интерфейса программы.

Завершение установки

После того, как вы нажмёте «Установить», MyTestX будет установлена. Если не произошло никаких ошибок, установка будет завершена через несколько секунд. Нажмите «Завершить» для полного ее завершения.

После установки программа будет видна в списке установленных программ в Панеле управления.

Если в процессе установки вы указали (не отменили) соответствующие опции, то на рабочем столе и в меню Пуск - Все программы появятся ярлыки программы. С помощью их можно быстро запускать программу.

Если в процессе установки вы указали (не отменили) ассоциацию файлов, то в дальнейшем файлы с тестами можно открывать двойным щелчком по файлу.

Установка программы из архива

Установка из архива достаточно проста, если вы знаете, как работать с архивами, файлами и директориями в ОС Windows. Вам просто следует распаковать скачанный файл в директорию на вашем диске, например "C:\MyTestX", а потом просто запустить нужный модуль программы из исполнительного файла с расширением «.exe». Распространённой практикой является создание ярлыков к этим файлу на Рабочем столе, меню "Пуск", или на панели быстрого запуска. Создать их можно либо средствами Windows, либо с помощью пунктов меню настройки (требуются права администратора).

В архиве:

  • MyTestStudent.exe - программа тестирования
  • MyTestEditor.exe - редактор
  • MyTestServer.exe - журнал
  • help.chm - справка
  • MyTestStudent_Config.txt - настройки программы тестирования
  • language.txt - файл с указанием языка интерфейса
  • ReadMe.doc
  • Tests\DemoTest01.mtf - примеры файлов с тестами
  • Tests\DemoTest02.mtf - примеры файлов с тестами
  • Tests\DemoTest03.mtf - примеры файлов с тестами
  • Tests\GIA2010inf.mtf - тест ГИА2010 по информатике

+ также другие тесты...

Так же в архиве с программой могут быть и другие служебные файлы, необходимые для работы каких-либо ее модулей. Наличие и название папок может изменяться в различных версиях программы.

Для удобства работы можно создать ярлыки и ассоциировать с файлами (см. настройки MyTestStudent).

Установка программы в операционной системе Linux

Программа MyTest X является приложением Windows, поэтому для её запуска под операционной системой Linux необходимо ПО, позволяющее запускать Windows-приложения из Linux. Что делать в этой ситуации? Использовать Wine.

Wine — это свободное программное обеспечение, позволяющее пользователям UNIX-подобных систем исполнять приложения Microsoft Windows. Название Wine является рекурсивным акронимом и расшифровывается «Wine Is Not an Emulator» — «Wine — не эмулятор».

Wine воспринимает системные вызовы Windows-приложений к библиотекам операционной системы и подменяет их своими. Таким образом, эмуляции процессора, аналогично другим эмуляторам, не происходит, и приложения могут выполняться в Wine почти так же быстро, как и в «родной» операционной системе. Для своей работы Wine не требует наличия установленной ОС Windows, хотя и может использовать её библиотеки.

Используя Wine вы можете устанавливать и запускать различные программы, как будто вы находитесь в Windows. Wine активно развивается. Ещё не все приложения нормально работают в Wine, однако, Wine уже используется несколькими миллионами пользователей по всему миру. При этом Wine не требует от вас покупки лицензионной копии Windows!
Таким образом, в вашем дистрибутиве Linux вам достаточно установить Wine и дальше устанавливать и использовать MyTest X так, как будто вы используете Windows.

На странице видео-помощи по программе MyTestX, расположенной по адресу http://mytest.klyaksa.net/wiki/VideoHelp, находятся ролики по установке программы в различных дистрибутивах Linux (AltLinux, Ubuntu, Mandriva).

См. также:

  • Установка программы MyTest
  • Установка MyTest и использование MyTest для "сетевого тестирования"
  • Настройка MyTestStudent


Установка MyTest и использование

Установка MyTest и использование MyTest для "сетевого тестирования"

Установка MyTest и использование MyTest для "сетевого тестирования"

Пусть в классе 1 компьютер учителя (имя комп. Teacher) + 17 компьютеров учащихся (имя комп. Student01, Student02,...).

1. Устанавливаем, если еще не установлена, на нужные компьютеры программу MyTest X.

2. Запускам программу тестирования (MyTestStudent.exe) на комп. Teacher.

Заходим в Настройки - Параметры.

Выбираем вкладку Сеть.

- В поле IP или имя компьютера пишем Teacher.

- Поле порт не меняем.

- Ставим галочку Отправлять результаты на сервер учителю.

- Нажимаем кнопку Применить (для того чтобы применить данные настройки).

Выбираем вкладку Сохр. настроки.

- Жмем кнопку Сохранить настройки сейчас (для того чтобы они записались с файл настроек MyTestStudent_Config.txt).

Закрываем окно настроек.

Закрываем MyTestStudent.

п.с. Можно было просто сразу в блокноте изменить файл MyTestStudent_Config.txt п.с. В окне настроек Сеть есть кнопка "Проверить связь", которая поможет проверить введенные настройки. Только не забудьте перед этим запустить Журнал (с которым будете тестировать соединение).

3. Проводим аналогичные настройки на всех других компьютерах (Student01, Student02...Student17) .

п.с. Для того чтобы сэкономить время, можно не проводить повторную настройку каждого из 17 компьютеров (программы на компьютере ученика), а просто скопировать файл MyTestStudent_Config.txt из папки с настроенной программой (скорее всего это папка C:\Program Files\MyTestX) в соответствующую папку на других компьютерах.

Все, класс к тестированию готов.

При помощи учеников на настройку класса можно потратить всего один раз всего пару минут.

Проведение "Сетевого тестирования"

1. Учитель (педагог, лаборант) запускает на комп. Teacher модуль Журнал (MyTestServer). На вкладке Раздать тест выбирает нужный файл (или файлы) и ставит галочку раздать файл с тестом.

2. Ученики (студенты) запускают модуль тестирования (MyTestStudent). Щелкают Файл - Получить по сети. Их программа связывается в Журналом, получает тест и открывает его. Щелкают Тест - Начать... и начинается тестирование.....

Процесс пошел....

Если раздаются сразу несколько файлов, то у ученика откроется окно, где он может выбрать требуемый ему файл.

Информация об получении теста, начале тестирования учеником... учителю отображается на вкладке Сообщения. Результаты тестирования на вкладке Результаты. После окончания тестирования результаты можно сохранить в файл (чтобы потом обработать или выставить оценки). Также можно проанализировать результаты сразу. Текущие результаты тестирования отображаются на вкладке Монитор.

См. также:

  • Установка программы MyTest
  • Установка MyTest и использование MyTest для "сетевого тестирования"
  • Настройка MyTestStudent


Модуль тестирования

Модуль тестирования

Модуль тестирования - это модуль программы MyTest X в котором учащиеся проходят тестирование. Программа проста в использовании и имеет удобный интерфейс. Но, не смотря, на вся ее простоту позволяет эффективно организовать тестирование, сохранение и отправку результатов учителю.

Имя файла модуля тестирования: MyTestStudent.exe.

Одновременно может работать только один экземпляр программы тестирования MyTest (для терминального класса используйте специальную версию). Т.е. открыть один тест для учителя, а другой для подбора ответа уже не получится.

Модуль тестирования может находится в одном из трех состояний: тест не выбран, тест выбран, тест идет. Текущие состояние отображается в строке состояния.

Открытие тестов

Тесты к программе MyTest X храниться в отдельных файлах, поэтому вам не потребуется выполнять никаких утомительных синхронизаций базы данных, как в некоторых других программах. Просто скопируйте файл с тестом на другой компьютер или в общую папку в сети и открывайте его. Также файлы с тестами можно получать по сети (см. модуль Журнала).

Вы можете использовать любой из следующих способов открытия теста:

  • Из меню Файл → Открыть ...
  • Двойным щелчком по файлу (необходимо ассоциировать разрешения файла с программой, см. параметры MyTestStudent)
  • Перетащив файл на иконку программы или ярлыка программы.
  • Перетащив файл на окно программы в состоянии "тест не выбран".
  • Получив тест от учителя по компьютерной сети (Из меню Файл → Получить по сети ... )(для этого необходимо настроить сеть; учителю запустить модуль Журнала тестирования и указать тест или тесты для учащихся).

После открытия теста в окне вы увидите сообщение об названии теста и критериях оценивания (эту информацию и другие параметры тестирования можно посмотреть и позже из меню Тест → Информация).

Открытые тесты автоматически добавляются в подменю "Предыдущие файлы" меню "Файл" для более удобного открытия их в следующий раз.

Для того чтобы выбрать другой тест необходимо закрыть текущий.

Прохождение теста

Выбор правильного варианта ответа производится либо щелчком мыши, либо клавишами на клавиатуре. См. типы тестовых заданий.

Если вы уверены в ответе для перехода к следующему вопросу нажмите кнопку "Дальше" либо на клавиатуре ENTER или ПРОБЕЛ.

Индикатор под кнопкой "Дальше (проверить)" отображает ход теста, т.е. количество заданных на данный момент вопросов.

К каждому заданию может быть прикреплен рисунок (в форматах *.png, *.gif, *.jpg, *.jpeg, *.bmp, *.ico, *.emf, *.wmf). Если имеется рисунок, то его миниатюра отображается справа от текста задания (кроме задания на выбор места на рисунке). Для просмотра рисунка в полный размер достаточно по нему щелкнуть мышкой - рисунок откроется в новом окно. Размер окна с рисунком можно изменять произвольным образом (хоть во весь экран), при этом рисунок будет соответственно увеличиваться или уменьшаться. При открытом рисунке можно отвечать на задание. При переходе к другому заданию, если рисунок не был закрыт, он закроется автоматически. Примечание: хотя рисунки можно вставлять непосредственно и в тест вопроса и вариантов, большие рисунки лучше прикреплять отдельно (так удобнее тестируемому).

К каждому заданию может быть прикреплен звуковой файл (в форматах *.mp3, *.wav). Если имеется звуковой файл, то в окне Модуля тестирования появится панель плеера с кнопками запуска, остановки и перемотки музыки.

Размер окна программы можно менять произвольным образом. Так же есть возможность изменить размер области отводимой для вопроса задания. Для этого наведите мышь на границу области вопроса и вариантов ответа и перемещайте с нажатой кнопкой мыши. В параметрах программы можно задать опцию запоминать размер и положения окна.

Нижняя часть окна программы представляет информацию об количестве вопросов в тесте и количестве заданных вопросов (текущий/всего), времени затраченного на весь тест и на текущее задание, режиме тестирования, имени тестируемого. Если включено ограничение по времени, то так же будет отображаться оставшееся время на обдумывания задания или всего теста. После окончания выделенного на обдумывание времени выводится соответствующее сообщение и производится переход к следующему вопросу (или заканчивается тест и выводятся результаты). Если на данный момент был выбран правильный вариант ответа, то он будет принят. Если время обдумывания заканчивается оно будет выделено красным цветом. При "Свободном режиме", если для заданий задано ограничение по времени, то оно запоминается. Например, для задания стоит ограничение 30 секунд. Как бы ученик не выбирал задания, но суммарное время показа этого задания не может превысить указанное значение.

В зависимости от режима тестирования кроме кнопки "Далее (проверить)" может быть показаны и другие кнопки, например, "Я не знаю" и "Пропустить". Так же в "Свободном режиме" показывается список заданий для быстрого перехода к любому из них.

Для более комфортной работы пользователь может установить масштаб шрифта для текста вопроса и вариантов ответа. Для этого необходимо воспользоваться командой "Настройка → Масштаб → (Крупнее/Обычный(100%)/Мельче)".

Так же для удобства тестируемого можно открыть текст вопроса или варианта ответа в отдельном окне. Для этого необходимо сделать двойной щелчок по этому тексту. Масштаб, в открывшемся окне, меняется комбинацией клавиш: Shift + + - крупнее, Shift + - - мельче.

Текст вопросов и вариантов ответа защищен от копирования. Ни с помощью комбинации клавиш, ни с помощью меню скопировать его нельзя.

Если для ответа на задание требуется калькулятор, то его можно быстро вызвать нажав на клавиатуре комбинацию клавиш Alt и = (равно).

Окончание тестирования

По окончанию теста выводится окно с оценкой. Так же эта информация (но более подробная) выводится в поле информации (поле вопроса). В окне с оценкой показываются две диаграммы - одна статистика по вопросам, другая по баллам. Цвета на диаграмме №1 означают: белый - вопросов пропущено (тест был остановлен или закончилось время), зеленый - ответов правильно, красный - ошибок. Цвета на диаграмме №2 означают: зеленый - баллов набрано, красный - баллов не набрано из-за ошибок. Количество баллов за ответ для каждого задается в редакторе тестов.

Для удобства учителя можно задать звук, который будет воспроизведен сразу по окончанию тестирования. Можно использовать как включенные в программу звуки, так и свои.

Если произведены соответствующие настройки и данные параметры включены в тесте, то результаты теста будут также отправлены по компьютерной сети на сервер учителю (в модуль Журнал) или по электронной почте.

Так же, при включенной настройке "Сохранять результаты в файл", подробные результаты сохраняются в файл результатов. Этот файл удобен для чтения человеком. Кроме этого файла результаты можно записывать в "защищенный файл". Защищенные результаты можно открыть (импортировать) в модуле Журнал, изменить и пересохранить их нельзя. Так же защищенные результаты защищены паролем (задается для каждого теста отдельно в редакторе). По умолчанию файлы с результатами находится в каталоге с программой, но вы можете указать другое место в настройках программы.

Система оценки задается при создании теста без необходимости менять какие-либо настройки программы. Шкала оценок может быть не только пятибалльная, но и любая другая (десятибалльная, двенадцатибальная, стобальная, зачет/незачет, ... - любая!).

Так же в конце тестирования может быть показан отчет, где выводится задание с вариантами, верно отвечено или нет и верный(ые) ответ(ы).

Внимание! Способ вывода информации о результатах тестирования зависит от настроек теста, заданных в редакторе именно для этого теста. Например, если в редакторе для этого файла с тестом запрещено показывать окно результатов, то никакие настройки модуля тестирования не включат его. Тоже самое относится и к записи результатов в файлы и отправке по сети, по электронной почте...

См. также:

  • Модуль тестирования
  • Редактор тестов
  • Журнал тестирования


Типы заданий

Типы заданий

Программа MyTest работает с девятью типами заданий:

  • Одиночный выбор

Тестируемому предлагается выбрать только один вариант ответа из нескольких предложенных.

  • Множественный выбор

Тестируемому предлагается выбрать один или несколько вариантов ответа из нескольких предложенных.

  • Указание порядка следования

Тестируемому предлагается упорядочить список. Для этого нужно для каждого элемента (варианта ответа) выбрать из выпадающего списка его порядковый номер. Раскрывающиеся списки аналогичны меню. В свернутом состоянии раскрывающийся список отображает только текущий выбранный параметр. Другие доступные параметры скрыты до щелчка кнопки со стрелкой.

  • Сопоставление вариантов

Вопрос на сопоставление предполагает выбор номера соответствующего варианта из всех предложенных. Т.е. даны два столбика - для каждого варианта из первого столбика необходимо указать соответствующий вариант из второго. Вопрос с сопоставлением удобно применять в случаях, когда требуется упорядочить элементы или сгруппировать какие либо элементы по определенным признакам.

  • Указание истинности или ложности утверждений (MCQ)

Вопрос предполагает выбор утверждения "да", "нет", пусто (не знаю) из списка для всех предложенных вариантов. Раскрывающиеся списки аналогичны меню. В свернутом состоянии раскрывающийся список отображает только текущий выбранный параметр. Другие доступные параметры скрыты до щелчка кнопки со стрелкой.

  • Ручной ввод числа

Вопрос на ручной ввод числа предполагает ввод числа или нескольких чисел в качестве ответа. Правильный ответ, при создании теста, может быть задан в виде числа, или в виде числового диапазона. В последнем случае ответ тестируемого считается правильным если он попадает в указанный диапазон.

  • Ручной ввод текста

Вопрос на ручной ввод текста предполагает введение текстовой строки в качестве ответа.

При создании теста можно задать не один, а несколько вариантов ответа. Ответ считается верным если совпадает хоть с одним из вариантов. Т.е. вы можете предусмотреть возможные опечатки (например, позиционная и позиционая) или неоднозначности ввода (например, алгоритм и алгоритмом). Так же вы можете указать учитывать или нет регистр символов.

  • Место на изображении

Для ответа на вопрос типа место на изображении необходимо указать точку на изображении. Если она попадает в указанную область ответ верен. На рисунке можно задать не одну, а несколько областей.

  • Перестановка букв

Ответом к этому типу заданий является слово (или текст). Буквы нужного слова выводятся в отдельных областях и в случайном порядке. Тестируемый может, щелкая мышью, обменивать буквы местами. Хорошо подходит для детей младшего возраста.

+ Так же тип Да/Нет может быть получен из Одиночного выбора, добавив всего два варианта 1) да и 2) нет. Таким образом, можно считать, что программа поддерживает десять типов заданий!

В любой момент есть возможность изменить тип заданий. При преобразовании автоматически учитывается из какого типа в какой происходит преобразование.

См. также

  • Тесты MyTest


Тесты MyTest

Тесты MyTest

Тест - это система тестовых заданий, параметров и правил их применения.

Задания, параметры тестирования, звуки и изображения к заданиям для каждого отдельного теста - все хранится в одном файле теста. Никаких баз данных, никаких лишних файлов - один тест – один файл. Файл с тестом зашифрован и сжат.

Тестовое задание

Тестовое задание — составная часть педагогического теста.

Программа MyTest поддерживает девять типов заданий (одиночный выбор, множественный выбор, установление порядка следования, установление соответствия, указание истинности или ложности утверждений, ручной ввод числа (чисел), ручной ввод текста, выбор места на изображении, перестановка букв). Задание типа да/нет легко можно получить, используя тип с одиночным выбором. В тесте можно использовать любое количество любых типов, можно только один, можно и все сразу.

Задание состоит из вопроса (возможно несколько формулировок) и, в зависимости от типа, вариантов ответа или требуемого ответа. Текст вопроса и вариантов может содержать форматированный текст, рисунки и формулы.

К каждому заданию можно прикрепить рисунок, который будет показан в отдельном окне (удобно для больших рисунков). Причем, при использовании одного и того же рисунка в разных заданиях, не увеличивается размер файла с тестом.

Так же к заданию можно прикрепить звуковой файл в формате mp3 или wav. В этом случае в окне модуля тестирования появится панель с медиаплеером. При использовании звуков, необходимо помнить, что они значительно увеличивают размер файла с тестом.

Для каждого задания в тесте можно индивидуально задать сложность (количество баллов за верный ответ) от 1 до 100, максимальное время обдумывания задания.

К каждому заданию может быть прикреплено вступление - текст, который будет показан вначале показа задания, подсказка (показ может быть за штрафные баллы) и объяснение верного ответа. Вступление и объяснение показываются в обучающем режиме.

Количество заданий в тесте не ограничено. В заданиях с выбором ответа (одиночный, множественный выбор, указание порядка, указание истинности) можно использовать до 10 (включительно) вариантов ответа. В задании на ввод числа можно требовать ввод до 5 (включительно) чисел.

Параметры теста и правила применения

Каждый тест может содержать:

Заголовок теста. Автор (составитель) теста. Электронная почта автора. Описание теста.

Инструкцию тестируемому - сообщение, которое будет показано тестируемому в начале теста. Позже это сообщение можно посмотреть по команде Тест - Инструкция. Инструкция может содержать форматированный текст, рисунки и формулы.

Заметки - это текст, который не виден тестируемому. Прочитать его или изменить можно только открыв тест в редакторе. В заметках можно хранить любую информацию. Например, что и в каком задании хочется изменить, какие-то замечания по тесту и т.д. Заметки могут содержать форматированный текст, рисунки и формулы.

Оценивание

Оценка учащегося вычисляется по баллам. Уровень оценки в процентах (для того чтобы не менять при удалении/добавлении заданий) задается в редакторе тестов. Система оценки может быть любой - от двухбалльной (зачет/незачет) до 100-балльной. Для оценки можно указать название - тогда выводится не цифра, а название (полезно для зачет/незачет). В редакторе для удобства имеются часто применимые шаблоны оценивания, вы можете использовать их, а можете задать свои критерии оценивания.

В редакторе вы можете указать засчитывать только 100% верные ответы или учитывать неполные ответы (например, в множественном выборе отмечены не все или, наоборот, лишние варианты). Частичное засчитывание рекомендуется применять только в тестах с заданиями на указание истинности или ложности утверждений. Тогда получается классический Multiple Choice Question.

Порядок вопросов: обычный или случайный. Задает, в каком порядке тестируемому будет предложены задания. Для случайного порядка перемешивание заданий происходит при каждом запуске теста.

Порядок вариантов: обычный или случайный. Задает в каком порядке тестируемому будет предложены варианты ответов. Если включен случайный порядок, то у разных учеников будет различный порядок вариантов ответа.

Формулировка: случайная, основная, вторая и т.д. Задание теста может содержать несколько формулировок вопроса (от 1 до 5). Если указанной формулировки в задании нет, то выводится основная.

Темы (группы заданий)

Темы, или группы, заданий предназначены для удобного разделения заданий на группы и ограничения количества заданий для ученика. Вы можете указать, сколько именно заданий из какой темы будет задано. При ограничении количества заданий они выбираются случайным образом.

Количество тем в тесте не ограничено. Изменить тему задания можно в любой момент.

Ограничение по времени. Вы можете ограничить не только время обдумывания каждого задания, но и время всего теста. Ограничение для задания указывается при редактировании заданий, ограничение для всего теста в меню Параметры тестирования.

Ограничение на количество запусков. Вы можете указать максимальное количество запусков теста до перезагрузки компьютера. Т.е. если укажите 3, то тест можно будет запустить (начать тестирование) 3 раза. Чтобы еще запустить потребуется перезагрузить компьютер.

Пароли. Ваши тесты надежно защищены. Для удобства вы можете задать пароль на открытие теста для тестирования, открытие теста для редактирования, на запуск тестирования, для сохранения защищенных результатов.

Режимы тестирования. В программе предусмотрены несколько независимых друг от друга режимов тестирования: Обучающий - при ошибке тестируемый получает соответствующее сообщение и может посмотреть объяснение задания (если оно вами задано). Ошибочные и верные варианты подсвечиваются разными цветами. Можно задать объяснение ошибки, которое будет показано пользователю. Штрафной - при ошибке у тестируемого будут отниматься баллы. В этом режиме дополнительно появляется кнопка "Я не знаю...". Щелчок по ней присваивает за задание нуль баллов. Этот режим работает по-разному в зависимости от настроек оценивания (засчитывать 100% верные ответы или нет). В типе заданий "указание истинности или ложности" для каждого варианта, кроме "да" и "нет", присутствует пустой вариант - нуль баллов за вариант. Свободный - позволяет перемещаться по заданиям в любом порядке. В любой момент можно вернуться к заданию, если на него еще не дан ответ. Дополнительно появляется кнопка "Пропустить" - переход к следующему заданию без ответа (позже можно вернуться) и список заданий (в котором по-разному отмечены просмотренные и выполненные задания), позволяющий перейти к любому невыполненному заданию. Монопольный - окно программы занимает весь экран и его невозможно свернуть.

Параметры тестирования и вывода результатов:

Вы можете задать ограничения для теста

  • время на весь тест (время на каждое задание можно уставновить индивудуально)
  • количество запусков теста до перезагрузки компьютера
  • количество ошибок после которого тест будет автоматически остановлен
  • период (от какой до какой даты) использования теста
  • отправлять результаты по электронной почте
  • задать минимальный процент заданий для вывода результата (используется для защиты ответов методом подбора)

Вы можете разрешить/запретить

  • показывать результат тестируемому
  • сохранять результат в текстовый файл
  • сохранять результат в защищенный файл
  • отправлять результаты по сети модулю Журнал
  • отправлять промежуточные результаты по сети модулю Журнал для вкладки Монитор
  • отправлять результаты по электронной почте
  • показывать подробный отчет тестируемому по окончанию теста (выводится текст всех заданных заданий и указание верно или нет отвечено)
  • показывать/подсвечивать правильный ответ в обучающем режиме

См. также

  • Типы заданий


Одиночный выбор

Одиночный выбор

Тестируемому предлагается выбрать только один вариант ответа из нескольких предложенных.

Например: Какой месяц идет после марта?

  • январь
  • апрель
  • июнь
  • август
  • ноябрь

Это можно сделать двумя способами: Щелкнуть по соответствующему переключателю левой кнопкой мышки. Переключатели позволяют выбрать только один из двух и более параметров. Нажать на клавиатуре цифру - номер варианта от 1 до 5 (в зависимости от количества вариантов в задании).

После того, как выбран желаемый вариант ответа, то для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Множественный выбор

Множественный выбор

Тестируемому предлагается выбрать один или несколько вариантов ответа из нескольких предложенных.

Например: Перечислите весенние месяцы:

  • март
  • апрель
  • август
  • май
  • декабрь

Это можно сделать двумя способами: Щелкнуть по переключателю левой кнопкой мышки. В отличие от переключателей, ограничивающих возможность выбора одним вариантом, флажки позволяют выбирать несколько вариантов одновременно. Нажать на клавиатуре номер варианта от 1 до 5 (в зависимости от количества вариантов в задании). Если до нажатия переключатель не был выбран - он станет выбран, если же уже был выбран, то станет не выбран.

После того, как выбран желаемый вариант ответа, то для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Указание порядка следования

Указание порядка следования

Тестируемому предлагается упорядочить список. Для этого нужно для каждого элемента (варианта ответа) выбрать из выпадающего списка его порядковый номер. Раскрывающиеся списки аналогичны меню. В свернутом состоянии раскрывающийся список отображает только текущий выбранный параметр. Другие доступные параметры скрыты до щелчка кнопки со стрелкой.

Например: Расположите месяцы в порядке следования их друг за другом:

  • ? март
  • ? январь
  • ? февраль
  • ? май
  • ? апрель

Это можно сделать двумя способами: Щелкнуть по раскрывающемуся списку левой кнопкой мышки и выбрать нужный порядковый номер. Нажать на клавиатуре номер варианта от 1 до 5 (в зависимости от количества вариантов в задании). Нажатие клавиши 1 позволяет перебрать номера в списке для первого варианта, клавиши 2 - для второго и т.д. При нажатии клавиш происходит переход к следующему значению списка по кругу, т.е. 1-2-3-4-5-1-2...

Если тестируемый укажет два одинаковых номера, то около них появится значок вопроса и кнопка Далее станет не доступно. Это позволяет избежать случайных ошибок при ответе.

После того, как выбран желаемый вариант ответа, то для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Сопоставление вариантов

Сопоставление вариантов

Вопрос на сопоставление предполагает выбор номера соответствующего варианта из всех предложенных. Т.е. даны два столбика - для каждого варианта из первого столбика необходимо указать соответствующий вариант из второго. Вопрос с сопоставлением удобно применять в случаях, когда требуется упорядочить элементы или сгруппировать какие либо элементы по определенным признакам.

Например: Укажите к какому времени года относятся какие месяцы.

  • ? январь 1 зима
  • ? август 2 лето
  • ? май 3 осень
  • ? сентябрь 4 весна
  • ? декабрь

Это можно сделать двумя способами: Щелкнуть по раскрывающемуся списку левой кнопкой мышки и выбрать нужный порядковый номер. Нажать на клавиатуре номер варианта от 1 до 5 (в зависимости от количества вариантов в задании). Нажатие клавиши 1 позволяет перебрать номера в списке для первого варианта, клавиши 2 - для второго и т.д. При нажатии клавиш происходит переход к следующему значению списка по кругу, т.е. 1-2-3-4-5-1-2...

После того, как выбран желаемый вариант ответа, то для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Указание истинности или ложности

Указание истинности или ложности утверждений (MCQ)

Вопрос предполагает выбор утверждения "да", "нет", пусто (не знаю) из списка для всех предложенных вариантов. Раскрывающиеся списки аналогичны меню. В свернутом состоянии раскрывающийся список отображает только текущий выбранный параметр. Другие доступные параметры скрыты до щелчка кнопки со стрелкой.

Например: Месяц март ...

  • ? наступает сразу после апреля.
  • ? в северном полушарии является весенним месяцем.
  • ? длится 30 дней.
  • ? содержит в названии букву "р".
  • ? в году третий по порядку.

Это можно сделать двумя способами: Щелкнуть по раскрывающемуся списку левой кнопкой мышки и выбрать нужное значение из списка. Нажать на клавиатуре номер варианта от 1 до 5 (в зависимости от количества вариантов в задании). Нажатие клавиши 1 позволяет перебрать номера в списке для первого варианта, клавиши 2 - для второго и т.д. При нажатии клавиш происходит переход к следующему значению списка по кругу, т.е. , 'Да', 'Нет'...

См. также

  • Типы заданий


Ручной ввод числа

Ручной ввод числа

Вопрос на ручной ввод числа предполагает ввод числа или нескольких чисел в качестве ответа. Правильный ответ, при создании теста, может быть задан в виде числа или в виде числового диапазона. В последнем случае ответ тестируемого считается правильным если он попадает в указанный диапазон.

Каждое поле для ввода числа может иметь подпись. Это удобно при использовании ввода нескольких чисел.

Также имеется возможность не учитывать порядок введенных чисел. Например, при вводе корней квадратного уравнения не важно в какое поле ввести какое значение, лишь бы были нужные значения.

Например: Каким по счету идет месяц май? или Чему равна глубина черного моря?

При вводе ответа тестируемый может ввести только число (буквы и др. знаки игнорируются). Так же не возникает проблем с символом для разделения целой и дробной части - можно вводит либо точку, либо запятую - программа сама подкорректирует символ.

После того как введен вариант ответа для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Ручной ввод текста

Ручной ввод текста

Вопрос на ручной ввод текста предполагает введение текстовой строки в качестве ответа.

При создании теста можно задать не один, а несколько вариантов ответа. Ответ считается верным если совпадает хоть с одним из вариантов. Т.е. вы можете предусмотреть возможные опечатки (например, позиционная и позиционая) или неоднозначности ввода (например, алгоритм и алгоритмом). Так же вы можете указать учитывать или нет регистр символов.

В качестве вариантов ответа можно использовать регулярные выражения. Это позволяет более гибко использовать этот тип заданий. Если включен Обучающий режим, то в качестве верного ответа будет показан первый (первая строка из нескольких возможных). Поэтому, если используете регулярные выражения, рекомендуется первый вариант задавать просто в виде текста.

Пример: Какой месяц идет после августа?

После того как введен вариант ответа для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Место на изображении

Место на изображении

Для ответа на вопрос типа место на изображении необходимо указать точку на изображении. Если она попадает в указанную область ответ верен. В качестве области верного ответа можно использовать несколько областей.

Пример: Укажите инструмент "Заливка" графического редактора Paint.

Для указания места необходимо просто щелкнуть по требуемому месту на рисунке левой кнопкой мыши. Выбор можно изменить сколько угодно раз (до нажатия кнопки "Дальше"). Выбранное место отмечается специальной меткой.

После того как указано место для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Перестановка букв

Перестановка букв

Ответом к этому типу заданий является слово (или текст). Буквы нужного слова выводятся в отдельных областях и в случайном порядке. Тестируемый может, щелкая мышью, обменивать буквы местами. Хорошо подходит для детей младшего возраста.

При создании задания этого типа в редакторе просто указывается нужное слово (нужный текст). Буквы будут показаны тестируемому в случайном порядке автоматически.

После того как получен верный ответ для перехода к следующему вопросу достаточно нажать либо клавишу Enter, либо клавишу Пробел, либо щелкнуть по кнопке "Дальше" мышкой.

См. также

  • Типы заданий


Да/Нет

Да/Нет

Так же тип Да/Нет может быть получен из Одиночного выбора, добавив всего два варианта 1) да и 2) нет.

См. также

  • Типы заданий


В программе использованы

Место на изображении

В программе используются некоторые значки из наборов Basic Set, Crystal, Silk Icons.

Используется Компоненты Delphi и C++Builder для редактирования форматированного текста